Friday, November 21, 2014

When VPN connects but internet does not work

Do the following on the server:

sudo iptables -t nat -A POSTROUTING -s 10.8.0.0/24 -o eth0 -j MASQUERADE

sudo su
echo "1" > /proc/sys/net/ipv4/ip_forward

Monday, November 17, 2014

Burn ISO into a USB on a mac and boot with it

1. Download the ISO image.

2. Open the Terminal.

3. Convert the .iso file to .img using the convert option of hdiutil e.g.,
hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso

Note: OS X tends to put the .dmg ending on the output file automatically.

4. Run
diskutil list
to get the current list of devices.

5 Insert your flash media.

6 Run
diskutil list
again and determine the device node assigned to your flash media (e.g. /dev/disk2).

7 Run
diskutil unmountDisk /dev/diskN
(replace N with the disk number from the last command; in the previous example, N would be 2).

8 Execute
sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m
(replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img or ./ubuntu.dmg).

Using /dev/rdisk instead of /dev/disk may be fasterIf you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1MIf you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the 'Disk Utility.app' and unmount (don't eject) the drive

9 Run
diskutil eject /dev/diskN
and remove your flash media when the command completes.

10
Restart your Mac and press alt/option key while the Mac is restarting to choose the USB stick.

Sunday, November 16, 2014

Fix older versions of programs showing up in "open with" / "right click" dialogue in mac / apple / mavericks.

Fix older versions of programs showing up in "open with" / "right click" dialogue in mac / apple / mavericks.

Open a Terminal and type the following and press enter.

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

and restart.

Voila.